Skip to main content
All CollectionsFrequently Asked Questions
What is needed from the user to use the software?
What is needed from the user to use the software?
Updated over a week ago

To access Viima, all that is needed is a modern web browser and an account with which to log in.

All recent versions of the most common browsers are currently supported, including:

  • Google Chrome

  • Safari

  • Microsoft Edge

  • Mozilla Firefox

Please note that Microsoft has ended support for Internet Explorer and we have ended support for IE along the way. You may still be able to use certain parts of Viima with IE, but you will likely experience an increasing number of challenges as we continue to develop the software.

Mobile devices are also supported. In case you want to use Viima with mobile devices, you might also be interested in our mobile apps.

Did this answer your question?